Comunidade DATAB

Seja bem vindo ao fórum oficial da DATAB | Sua dose diária de Power BI e Excel

Dúvidas sobre cálculos, funções simples e aninhadas, fórmulas matriciais, etc.
  • Avatar do usuário
#70689
Estou com um problema, tenho um relatorio que gera data com horarios pela formula =agora() via vba (12/04/2022 12:30) e tenho uma fomula que precisa contar quantas vezes o dia X aparece na tabela (cont.ses).

porem como a formula =agora() dar valores quebrados, quando peço para contar quantas vezes a data 12/04/2022 aparece , ele não reconhece

quando aplico a formula, ele conta = 0, como se n existisse.
#70692
Considerei a data "X" em C1.
Código: Selecionar todos
=SOMARPRODUTO((INT(A1:A50)=C1)*(A1:A50<>""))
#70705
Você poderia disponibilizar o seu arquivo Excel diretamente aqui no fórum com a fórmula que passei ?
#70707
Abel, Bom Dia.

Uma forma de fazer, lembrando é formula matricial para versão anterior 2019 deve encerrar com CTRL+SHIFT+ENTER

=SOMA(SE((INT(Tabela13[DATA]))=(D29);1;0))

Espero ter ajudado

Decio
#70708
Retorna erro porque A1 contém texto. Altere a célula inicial para A2.
Código: Selecionar todos
=SOMARPRODUTO((INT(A2:A50)=D29)*(A2:A50<>""))
ou
Código: Selecionar todos
=SOMARPRODUTO((INT(Tabela13[DATA])=D29)*(Tabela13[DATA]<>""))
Ambas retornam 8.
#70710
OK, agora tenho outro problema q com essas formula eu n consigo resolver, preciso contar com condições,

contar quantas vezes a data aparece, e com a condição de que na coluna posterior ter um valor expecifico.

ex: =cont.ses(coluna1;12/04/2022;coluna2;"exemplo")
porem com essa formula não consigo contar as datas como dito anteriormente
#70711
Abel escreveu: 13 Mai 2022 às 15:07 contar quantas vezes a data aparece, e com a condição de que na coluna posterior ter um valor expecifico.
Coloque o "valor específico" em D30.

porem com essa formula não consigo contar as datas como dito anteriormente
Óbvio, pois não foi feita pra isso!
Código: Selecionar todos
=SOMARPRODUTO((INT(A2:A50)=D29)*(B2:B50=D30))

=SOMARPRODUTO((INT(Tabela13[DATA])=D29)*(Tabela13[FUNCIONARIO]=D30))

... mas quando tento recolher as linhas usando[…]

Valeu, meu caro Deciog! Abraço!!!!

Galera, agradeço a quem pelo menos se inter[…]

Olá, @piasserpa . Experimente: Sub Rep[…]

Olá queridos parceiros! Estou com um proble[…]

=ÚNICO(FILTRO(Tabela1[SEÇÃO];[…]

Olá, @CinOlive . Se você disponi[…]

Experimente: Sub CriarArquivoV2() Dim fat As R[…]